[Dovecot] Upgrading 1.2 to 2.x

Simon Brereton simon.buongiorno at gmail.com
Wed Mar 6 11:19:52 EET 2013

On 5 March 2013 23:25, Noel Butler <noel.butler at ausics.net> wrote:
> On Tue, 2013-03-05 at 11:33 +0100, Simon Brereton wrote:
>> Hi
>> I'm about to upgrade to 2.1.7 in my test environment, but  "doveconf
>> -n -c dovecot.1.conf > dovecot.2.conf" is producing a blank file, so I
>> am unsure how to proceed.  I know a lot has changed between them, so I
>> don't really want to have to start from scratch unless I have to.
>> I have tried both as my user and with sudo.
>> Simon
> Sounds like  symptom of an error or something in 1.conf, I found
> converting that if it strikes something it does not like it bails there
> and then, but it gave me about 80% conversion, only requiring  tweaking
> to finalise it, however it did not convert quota stuff to new format so
> start that from scratch.
> When you run convert it usually spits out what it is, or is not doing,
> that must give you some clue.
> and should matter what UID you are on, so long as you have read access
> to 1.conf and write access to 2.conf

So many replies - I feel like a celebrity! :)

Noel - this is what I get when I run the command.  As you can see
dovecot.2.conf is empty afterwards.

sbuongiorno at local:~$ doveconf -n -c dovecot.1.conf > dovecot.2.conf
doveconf: Warning: NOTE: You can get a new clean config file with:
doveconf -n > dovecot-new.conf
doveconf: Warning: Obsolete setting in dovecot.1.conf:4: 'imaps'
protocol is no longer necessary, remove it
doveconf: Warning: Obsolete setting in dovecot.1.conf:4: 'pop3s'
protocol is no longer necessary, remove it
doveconf: Warning: Obsolete setting in dovecot.1.conf:5: ssl_ca_file
has been replaced by ssl_ca = <file
doveconf: Warning: Obsolete setting in dovecot.1.conf:6: ssl_cert_file
has been replaced by ssl_cert = <file
doveconf: Warning: Obsolete setting in dovecot.1.conf:7: ssl_key_file
has been replaced by ssl_key = <file
doveconf: Warning: Obsolete setting in dovecot.1.conf:9: login_dir has
been removed
doveconf: Fatal: Error in configuration file dovecot.1.conf line 10:
Unknown setting: login_executable(imap-login)
spbrereton at local:~$ cat dovecot.2.conf
# 2.1.7: dovecot.1.conf
sbuongiorno at local:~$

What if I comment that line out?

What happens is I get a bit further.  I ended up having to comment out
the following lines:

#login_executable(imap)= /usr/lib/dovecot/imap-login
#login_executable(pop3)= /usr/lib/dovecot/pop3-login
#mail_executable(imap)= /usr/lib/dovecot/imap
#mail_executable(pop3)= /usr/lib/dovecot/pop3
#mail_plugins(imap)= quota imap_quota
#mail_plugins(pop3)= quota
#mail_plugin_dir(imap)= /usr/lib/dovecot/modules/imap
#mail_plugin_dir(pop3)= /usr/lib/dovecot/modules/pop3
#imap_client_workarounds(imap)= outlook-idle delay-newmail
#pop3_save_uidl(imap)= no
#pop3_save_uidl(pop3)= yes
#pop3_uidl_format(default)= %08Xu%08Xv
#pop3_uidl_format(imap)= %08Xu%08Xv
#pop3_uidl_format(pop3)= %v.%u
#pop3_client_workarounds(pop3)= outlook-no-nuls oe-ns-eoh

Some of those look pretty crucial, and some I know I've definitely changed.

However, once I commented them all, I am able to generate a
dovecot.2.conf - thanks for the hint!


More information about the dovecot mailing list