[Dovecot] Question regarding Postfix and Dovecot

Daniel Reinhardt cryptodan at gmail.com
Mon Mar 18 01:27:22 EET 2013


First thank you for taking the time to reply to this, but I tried using
various LDA Command line suggestions from various places on the net, and
Postfix is not even seeing that dovecot is listed in the master.cf file as
a unix socket.

I have tried using LMTP and again it is not seeing that postfix is
configured to use dovecot-lmtp as a mail delivery agent for postfix.  The
way postfix works with dovecot is via mail-stack-delivery and use of
mailbox_command that is set up within main.cf If I comment that out postfix
sends to default mode which is Maildir in the users /home directory.

I have configured SQL Lookups successfully for authentication within
postfix and dovecot, its just the mail delivery agent that is not working.
 I even tried the sudo method, and that also failed.

Don't get me wrong Dovecot is a nice piece of software, but maybe getting
rid of the multiple files could make things easier, and a couple of sample
configs could then be included in the source.

And I am here trying to learn something new that I could put to use in a
future job if I were ever told to setup an email server to replace an
exchange system to handle multiple domains for various people.

So thanks for allowing me to learn another process of setting up a server
with email.

Daniel Reinhardt

On Sun, Mar 17, 2013 at 8:50 PM, Timo Sirainen <tss at iki.fi> wrote:

> On 17.3.2013, at 18.11, Daniel <cryptodan at gmail.com> wrote:
> > First of all the wiki articles on dovecots site are poorly written
> compared to apache and postfix.
> It's the best I can do myself. I have no idea how they could be improved
> in any major way. They say that the software developer himself is the worst
> possible person to write its documentation, because he can't understand
> what others find difficult..
> > That is what I mean by lack luster the error logging is lack luster as
> it doesn't specify the file or the line error is on like many very well
> supported applications like apache and postfix and that makes dovecot not
> very user friendly.
> If there is a syntax error, Dovecot shows the file and line number. After
> that it should always mention the setting name that is causing trouble,
> which I'd think should be easy to grep from the configs.. I guess it could
> be useful to show the file+line for it, but that's quite a lot of code to
> add just to avoid a grep. It's also a bit tricky to do without wasting more
> memory (wasting memory in config / doveconf process is fine, but not
> elsewhere, and some settings won't get processed until later).
> > I owe no one an apology for stating my opinion and I have over 10 years
> of using open source software and dovecot is the application that I have
> used that given me such headache and grief to the point I have given up on
> this learning experience.
> Quickly browsing through this thread, I guess this is the main problem? :
> Mar 15 06:56:37 andromeda dovecot: lda(cryptodan): Fatal: setgid(8(mail)
> from mail_gid setting) failed with euid=1000(cryptodan),
> gid=1000(cryptodan), egid=1000(cryptodan): Operation not permitted (This
> binary should probably be called with process group set to 8(mail) instead
> of 1000(cryptodan))
> Yes, this is something I've been annoyed at for a long time. But it's also
> not easy to make that error any better, except maybe by creating a wiki
> page explaining the whole thing and linking to it. (There are a ton of
> mails about this exact thing in Dovecot list archies.) There's also no
> setting that is specifically related to this (the problem is a mismatch
> between Dovecot/Postfix configuration). There is a super easy solution
> though: use LMTP instead of LDA, and there are no permission troubles.
> Maybe that's what the LDA wiki page should say.. Done:
> http://wiki2.dovecot.org/LDA

Daniel Reinhardt
cryptodan at cryptodan.net

More information about the dovecot mailing list