[Dovecot] Multiple Concurrent IMAP Connections For Same User

Stephen Usher Stephen.Usher at earth.ox.ac.uk
Sat Mar 5 18:04:05 EET 2011

I know that this is a somewhat old thread but I do have some useful input.

Basically, this seems to be a Thunderbird problem (or at least an 
interaction problem between Thunderbird and Dovecot).

Before Thunderbird version 3 there wasn't a problem, the mailbox within 
Thunderbird would sync correctly. As of version 3 they seem to have 
changed their mailbox header list caching code and it gets horribly 
confused when mails disappear from the mailbox without it doing so. The 
only way to fix the view within the program is the rebuild the 
(Thunderbird) index.

This is not the only problem TB3 has with Dovecot. Quite often if there 
are large attachments TB doesn't fully load the attachments (and 
sometimes not even the mail itself). I've found changing TBs setting so 
that it only uses one connection to the server rather than the default 5 
helps mitigate this.

I'm not sure why TB3 has such a hard time when talking to Dovecot as no 
other clients have any difficulty and TB2 never did.


P.S. Our system is a Solaris 10 x86 box running Dovecot 1.2.x with 
Maildir++ folders.
IT Systems Administrator,                     E-Mail:- steve at earth.ox.ac.uk
Department of Earth Sciences,                    Tel:-   +44 (0)1865 282110
Oxford University, South Parks Road, Oxford, UK. Fax:-   +44 (0)1865 272072

More information about the dovecot mailing list